Cisco issued some 40 protection advisories these days however only one in every one of them become deemed “important” – a vulnerability in the Cisco Nexus 9000 Series Application Centric Infrastructure (ACI) Mode facts-middle switch that could let an attacker secretly get entry to system assets.

The exposure, which became given a Common Vulnerability Scoring System significance of nine. Eight out of 10, is defined as a hassle with relaxed shell (SSH) key-management for the Cisco Nexus 9000 that lets a faraway attacker connect to the affected system with the privileges of a root person, Cisco stated.

“The vulnerability is because of the presence of a default SSH key pair this is present in all devices. An attacker ought to make the most this vulnerability by means of opening an SSH connection via IPv6 to a targeted tool the usage of the extracted key substances. This vulnerability is only exploitable over IPv6; IPv4 is not vulnerable,” Cisco wrote.

This vulnerability affects Nexus 9000s if they’re jogging a Cisco NX-OS software program release prior to 14.1, and the employer said there have been no workarounds to address the problem.

However, Cisco has launched free software updates that deal with vulnerability.

The company additionally issued a “high” safety warning advisory for the Nexus 9000 that involves a make the most that could permit attackers to execute arbitrary operating-device commands as root on an affected tool. To prevail, an attacker might want valid administrator credentials for the tool, Cisco said.

The vulnerability is due to overly wide device-file permissions, Cisco wrote. An attacker could exploit this vulnerability by authenticating to an affected tool, growing a crafted command string and writing this crafted string to a specific report area.

Cisco has launched software updates that cope with this vulnerability.

Two different vulneraries rated “excessive” also concerned the Nexus 9000:

A vulnerability inside the background-operations capability of the Cisco Nexus 9000 software program should permit an authenticated, nearby attacker to benefit accelerated privileges as root on an affected device. The vulnerability is because of insufficient validation of person-supplied documents on an affected tool. Cisco said an attacker could take advantage of this vulnerability by logging in to the CLI of the affected tool and growing a crafted document in a particular listing at the filesystem.

A weakness inside the historical past-operations capability of the transfer software program could permit an attacker to log in to the CLI of the affected tool and create a crafted document in a selected directory at the filesystem. The vulnerability is because of inadequate validation of person-provided files on an affected device, Cisco said.
Cisco has launched a software program for these vulnerabilities as nicely.

Also a part of those safety signals has been some of “high” rated warnings approximately vulneraries in Cisco’s FirePower firewall collection.

For example, Cisco wrote that multiple vulnerabilities inside the Server Message Block Protocol preprocessor detection engine for Cisco Firepower Threat Defense Software may want to permit an unauthenticated, adjacent or faraway attacker to reason a denial of service (DoS) circumstance.

Yet another vulnerability in the internal packet-processing capability of Cisco Firepower software program for the Cisco Firepower 2100 Series should permit an unauthenticated, faraway attacker cause an affected device to stop processing traffic, ensuing in a DOS state of affairs, Cisco stated.

Software patches are to be had for these vulnerabilities.

Other products including the Cisco Adaptive Security Virtual Appliance and Web Security equipment had excessive priority patches as nicely.

Join the Network World groups on Facebook and LinkedIn to comment on subjects that are top of thoughts.